Anki 2.0.52 erro de dependência.

Ao instalá-lo o programa não abre e apresenta esse erro no terminal. Uso Fedora 30 KDE.

File "/usr/bin/anki", line 5, in
import aqt
File "/usr/share/anki/aqt/init.py", line 12, in
from aqt.qt import *
File "/usr/share/anki/aqt/qt.py", line 7, in
import sip
ImportError: No module named sip

Comentários

  • Eu tmb tive problemas com versões antigas do anki e F30.
    Atualize o Anki, já esta na versão 2.1.13 e esta funcionando normal no F30.

  • Preciso da antiga, pois tem funções dele que não tem na atual. Obrigado.

  • Digite seu comentário> @Vinin disse:

    Preciso da antiga, pois tem funções dele que não tem na atual. Obrigado.

    Se quiser dizer quais funções, eu posso indicar algum complemento.
    Pois eu uso a versão atual aqui e ele não funciona com nenhum complemento antigo. Mas tem complementos novos com as mesmas funções.

  • editado julho 8

    A função é do próprio Anki e se refere a cópia de ''html'' mantendo o aspecto de formatação do texto, por exemplo.

  • Usa o Anki em Flatpak? O meu está dando um som estranho entre os áudios quando estou estudando frases em inglês.

  • Eu uso pela instalação normal. E esta normal o áudio.
    Via flatpak eu instalei uma vez numa VM só p/ ver se funcionava.

  • Obrigado.

  • O bug do áudio aconteceu tanto na versão rpm e flatpak. Já no KDE Neon não ocorreu até o momento. Infelizmente minha máquina nunca se deu bem com o Fedora.

  • @Vinin qual bug? não conheço este programa, mas testei gravar minha voz em alguma função e funcionou, consegui gravar e ouvir..aqui não é lugar de lamentação amigo, mas sim para tentar ajudar, se você não está satisfeito não é obrigado a nada..

Entre ou Registre-se para fazer um comentário.