Erro ao tentar gerar snapshot no Virt-Manager

Olá, estou recebendo mensagem de erro ao tentar gerar snapshot de uma VM no Virt-Manager. A seguinte mensagem aparece:

Alguém já passou por este problema? Agradeço desde já o retorno.

Comentários

  • Qdo vc abre o virt-manager ele pede p/ vc validar a autenticação com sua senha né.
    Pelo nome da pasta ai, vc tem que estar executando com o usuario leonardo.
    Então confirma aew se vc esta executando o virt-manager com usuario leonardo.

    Se já estiver, tente executar o virt-manager com sudo ou o root. Só pra testes, pois é pra funcionar.

  • Seu usuario tem privilegios de administrador?

  • Olá @Chacal , sim meu usuário tem privilégios de administrador e até já adicionei ele no grupo do virt-manager. Ele não pede senha quando abro o programa. Antes mesmo de ver o teu feedback eu já tinha feito um teste aqui executando o programa pelo terminal, usando o sudo e dessa vez conseguiu criar o snapshot normalmente. Só não sei porque isso acontece, pois tenho privilégios de administrador e pertenço ao grupo virt-manager. Obrigado pelo retorno!

  • editado outubro 2019

    Olá @bsleonardo, estranho este comportamento dele não pedir senha qdo vc executa.
    A não ser que o seu virt-manager esteja com o QEMU/KVM desconectado qdo é executado com seu usuário.


    Faz assim, execute o virt-manager com seu usuario comum mesmo, sem sudo.

    Como ele não pede senha, deve estar desconectado conforme tela abaixo.

    Então clique com o botão direito em QEMU/KVM e depois conectar. Ele deve pedir sua senha. Vc insere a senha de boas e ele deve mudar o status p/ conectado (demora alguns segundos blz).



    Se for isso aew mesmo, ai basta configurar p/ ele iniciar o virt-manager e já carregar o qemu/kvm. Vc clica com o direito em QEMU/KVM e depois em detalhes. Ai vc marca a opção de conectar automaticamente.


    E faz uns testes.
    Espero que de tudo certo, senão diz aew p/ gente tentar algo diferente blz.
  • Olá @Chacal, o mistério continua, executando o virt-manager sem sudo, apenas clicando no ícone do programa, já aparece a janela sem aquela informação de que o QEMU/KVM não estão conectados. Sobre a outra opção de marcar a caixa de conectar automaticamente, a mesma já se encontrava marcada. Segue prints para mostrar o que eu disse.

  • Olá @bsleonardo, realmente ta um mistério rsrsrs.
    Mas é assim mesmo, faz parte. Vamos tentar e validar outras coisas diferentes então.

    Tente desativar o selinux, firewalld, os dois se for o caso e veja se algum deles estão bloqueando. Acredito que não seja isso, pois vc teria problemas com o root tmb ... eu acho né. Mas não custa nada validar.


    Desativando o selinux temporariamente

    status do selinux
    $ sestatus

    desabilitando selinux
    $ sudo setenforce 0

    Verifique o status novamente p/ ver se mudou e esta desabilitando.
    Estando ok, faz o teste com virt-manager.

    Se mesmo assim não der certo, mantenha o selinux desabilitado e desative o firewall temporariamente.
    $ sudo systemctl stop firewalld
    Testa dnovo o virt-manager.

    Para ativar selinux e firewalld.
    $ sudo systemctl start firewalld
    $ sudo setenforce 1



    Se persistir o problema, ai vamos pensar em mais alguma coisa que pode ser feito.
  • Olá @Chacal, não sei se foi erro meu em não ter dito isso antes, mas estou usando a distribuição Linux Mint 19.2 e nem o selinux e nem o firewalld estão presentes aqui. Rodei os comandos que me indicou e como retorno disse que não foi encontrado.

  • Olá @bsleonardo, ah ta tranquilo sem problemas rsrsrs.
    Eu não manjo mto de base Debian pq faz tempo que não uso.

    E os serviços são diferentes mesmo, no seu caso não sera encontrado selinux e nem o firewalld. Acho que no Mint é usado o apparmor no lugar do selinux e o UFW no lugar do firewalld.


    Tente parar estes serviços para testes. Pode ser que exista uma regra diferente do que teria no selinux ... tipo permitir a execução pelo root e não pelo seu usuario. Desativando da p/ tirar essa duvida.

    No caso do apparmor, acho que o comando é esse:
    $ sudo systemctl stop apparmor.service

    No firewall, pelo que eu li a respeito ele já vem desativado ... mas valida ai tmb.
    $ sudo ufw status
    $ sudo ufw stop
    ou
    $ sudo ufw disable


    Não tenho ctz se são estes os comandos rsrs.
Entre ou Registre-se para fazer um comentário.