[RESOLVIDO] Ruby on rails no Fedora 30

Gente estou tentando estudar rails, porém, não consigo instalar a gem no Fedora.
Já tentei gem install rails e não vai kk.
Já tentei dar um Google mas nenhuma solução me ajudou, a única que consegui instalar o rails, quando vou criar um projeto ele dá erro no sqlite3 e no nokogiri. Se alguém souber como me ajudar por favor kkk já estou a 1 semana nisso.

Comentários

  • Digite seu comentário> @GabrielSugai disse:

    Gente estou tentando estudar rails, porém, não consigo instalar a gem no Fedora.
    Já tentei gem install rails e não vai kk.
    Já tentei dar um Google mas nenhuma solução me ajudou, a única que consegui instalar o rails, quando vou criar um projeto ele dá erro no sqlite3 e no nokogiri. Se alguém souber como me ajudar por favor kkk já estou a 1 semana nisso.

    Me dê um tempinho que farei um tutorial aqui. Vou mandar o link assim que estiver pronto.

  • Digite seu comentário> @GabrielSugai disse:

    Gente estou tentando estudar rails, porém, não consigo instalar a gem no Fedora.
    Já tentei gem install rails e não vai kk.
    Já tentei dar um Google mas nenhuma solução me ajudou, a única que consegui instalar o rails, quando vou criar um projeto ele dá erro no sqlite3 e no nokogiri. Se alguém souber como me ajudar por favor kkk já estou a 1 semana nisso.

    Fiz um tutorial, mas usando o RVM, provavelmente vc vai ter que recomeçar para instalar igual ao que fiz no tutorial:
    https://fedorabr.org/index.php?p=/discussion/444/ruby-on-rails-com-rvm-no-fedora/p1?new=1

  • Digite seu comentário> @GabrielSugai disse:

    Gente estou tentando estudar rails, porém, não consigo instalar a gem no Fedora.
    Já tentei gem install rails e não vai kk.
    Já tentei dar um Google mas nenhuma solução me ajudou, a única que consegui instalar o rails, quando vou criar um projeto ele dá erro no sqlite3 e no nokogiri. Se alguém souber como me ajudar por favor kkk já estou a 1 semana nisso.

    Se vc quiser realmente continuar a instalação como estava fazendo, mostre o que vc já fez e as telas de erro. Se não, siga o meu tutorial.

  • @leandroramos disse:
    Digite seu comentário> @GabrielSugai disse:

    Gente estou tentando estudar rails, porém, não consigo instalar a gem no Fedora.
    Já tentei gem install rails e não vai kk.
    Já tentei dar um Google mas nenhuma solução me ajudou, a única que consegui instalar o rails, quando vou criar um projeto ele dá erro no sqlite3 e no nokogiri. Se alguém souber como me ajudar por favor kkk já estou a 1 semana nisso.

    Se vc quiser realmente continuar a instalação como estava fazendo, mostre o que vc já fez e as telas de erro. Se não, siga o meu tutorial.

    Ontem eu já havia desinstalado e instalado diversas vezes, nenhuma forma de baixar o rails que encontrei no Google deu certo, agora não consigo testar, a hora que chegar em casa eu vejo se consigo seguindo seu tutorial.

    Vlw maninho <3

  • @GabrielSugai não deixe de dar o retorno aqui, para podermos colocar o tópico como resolvido.

  • @leandroramos tentei e nao funcionou, entrei na documentaçao oficial e tentei instalar por ela, descobri um erro no gcc

    "gcc: error: /usr/lib/rpm/redhat/redhat-hardened-cc1: No such file or directory"

    utilizei o seguinte comando para corrigir
    sudo dnf install redhat-rpm-config

    e consegui instalar o rails com o gem install rails,

    Porem nao instalou uma gem

    Could not find bindex-0.8.1 in any of the sources

    e nao estou conseguindo instalar essa gem

  • @GabrielSugai precisa ter detalhes do que exatamente você fez. Quais foram os passos da instalação? Que erros vc obteve ao longo da instalação? Sem isso não tem como ajudar.

  • @leandroramos

    segui a documentação do rails oficial

    https://guides.rubyonrails.org/getting_started.html

    sudo dnf install ruby
    gem install rails

    o problema que eu estava tendo é que ao usar
    gem install rails

    eu recebia o seguinte erro:

    `To see why this extension failed to compile, please check the mkmf.log which can be found here:

      /home/gsgd/.gem/ruby/extensions/x86_64-linux/2.6.0/nokogiri-1.10.9/mkmf.log
    
    extconf failed, exit code 1
    
    Gem files will remain installed in /home/gsgd/.gem/ruby/gems/nokogiri-1.10.9 for inspection.
    Results logged to /home/gsgd/.gem/ruby/extensions/x86_64-linux/2.6.0/nokogiri-1.10.9/gem_make.out`
    

    então entrei nesse log que apareceu no meu terminal e vi esse erro:

    "gcc: error: /usr/lib/rpm/redhat/redhat-hardened-cc1: No such file or directory"

    entao eu dei um google nele, e encontrei como corrigir utilizando:
    sudo dnf install redhat-rpm-config

    depois disso eu consegui instalar o rails normalmente, esse erro do nokogiri não ocorreu mais, porem, agora a gem bindex não quer ser instalada.

    Quando eu dou o comando bundle install, o bindex é instalado
    Installing bindex 0.8.1 with native extensions

    Porem ao usar
    rails server

    aparece o seguinte erro:
    Could not find bindex-0.8.1 in any of the sources
    Run bundle install to install missing gems.

    Só que eu dou o comando bundle install e acontece a mesma coisa, ja tentei gem install index tambem.

  • Tente apagar o arquivo Gemfile.lock e rode o bundle install novamente, da seguinte forma:

    bundle install --path vendor/cache

  • editado março 18

    @leandroramos

    consegui resolver os erros, agora preciso instalar o yarn

    [gsgd@gsgd olamundo]$ rails webpacker:install
    Yarn not installed. Please download and install Yarn from https://yarnpkg.com/lang/en/docs/install/

    já entrei nesse link que aparece no terminal porem, não consegui instalar ainda,

    quando uso dnf install yarn, ele inicia o download, mas depois aparece o seguinte:

    Erro: Transaction test error:
    o arquivo /usr/bin/yarnpkg da instalação de yarn-1.22.4-1.noarch conflita com o arquivo do pacote yarnpkg-1.21.1-1.fc30.noarch

    Edit

    Usei dnf remove yarnpkg

    e dps dnf install yarn

    e consegui deu tudo certo

  • Beleza. Aproveite seu Rails. Vou colocar o tópico como resolvido. @GabrielSugai

Entre ou Registre-se para fazer um comentário.