Wireless Fedora 29 reconhece rede mas não conecta

editado abril 21 em Fedora

Tentei instalar o Fedora 29, reconhece o wireless mas não conecta, eu queria tanto testar o Gnome puro. Acabei voltando pro Mint, e detalhe, sempre tenho que instalar os drivers, no Ubuntu funciona, mas o problema persiste no amado OpenSuse e no Fedora não cheguei a testar, apenas rodar DVD. Tô com um Gabinete, o wireless dele é um tp-link Tl-wn823n v3 da preguiça levar ele lá para parte de baixo e conectar ao cabo de internet para fazer a instalação dos drivers. Quando eu rodo lsusb aparece que está conectado no Fedora, mas não chega conexão. No Ubuntu e derivados tenho que tirar e colocar o adaptador várias vezes para que funcione e depois baixo os drivers, e mesmo com ele funcionando corretamente quando rodo lsusb no Ubuntu não aparece o adaptador mas funciona perfeitamente, só não pisca a luz verde.

Alguém pode me ajudar?

lsusb

https://scontent.fcpv2-1.fna.fbcdn.net/v/t1.0-9/57382368_193426641637589_8887232546056699904_n.jpg?_nc_cat=103&_nc_ht=scontent.fcpv2-1.fna&oh=4434898ae283d083057a37e7d6e951fa&oe=5D47240E

lspci

https://scontent.fcpv2-1.fna.fbcdn.net/v/t1.0-9/57471807_193428124970774_1195392825584254976_n.jpg?_nc_cat=109&_nc_ht=scontent.fcpv2-1.fna&oh=6d7aa0a8257c5959a1ac645a704dbd49&oe=5D3DB5FE

No Mint

~$ lspci
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers (rev 06)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 610 (rev 04)
00:14.0 USB controller: Intel Corporation 100 Series/C230 Series Chipset Family USB 3.0 xHCI Controller (rev 31)
00:16.0 Communication controller: Intel Corporation 100 Series/C230 Series Chipset Family MEI Controller #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Q170/Q150/B150/H170/H110/Z170/CM236 Chipset SATA Controller [AHCI Mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #5 (rev f1)
00:1c.5 PCI bridge: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #6 (rev f1)
00:1c.6 PCI bridge: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #7 (rev f1)
00:1c.7 PCI bridge: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #8 (rev f1)
00:1d.0 PCI bridge: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #9 (rev f1)
00:1d.1 PCI bridge: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #10 (rev f1)
00:1f.0 ISA bridge: Intel Corporation H110 Chipset LPC/eSPI Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation 100 Series/C230 Series Chipset Family Power Management Controller (rev 31)
00:1f.3 Audio device: Intel Corporation 100 Series/C230 Series Chipset Family HD Audio Controller (rev 31)
00:1f.4 SMBus: Intel Corporation 100 Series/C230 Series Chipset Family SMBus (rev 31)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)

O que tenho que fazer para funcionar no Ubuntu e derivados: Conecto e disconecto o adaptador até uma hora que o Wi-Fi funciona. Depois rodo esses comandos:
sudo apt-get install git linux-headers-generic build-essential dkms
git clone https://github.com/Mange/rtl8192eu-linux-driver
cd rtl8192eu-linux-driver
sudo dkms add .
sudo dkms install rtl8192eu/1.0
echo "options 8192eu rtw_power_mgnt=0 rtw_enusbss=0" | sudo tee /etc/modprobe.d/8192eu.conf
echo "blacklist rtl8xxxu" | sudo tee /etc/modprobe.d/rtl8xxxu.conf

Mas no Fedora não funciona nem mesmo com esse "macete."

Comentários

  • editado abril 21

    tenho um realtek, e ele só funciona bem com uma configuração correta no roteador wifi, tente deixar igual a minha, ou teste outras opções no seu roteeador
    obs: teste outros canais tbm..

Entre ou Registre-se para fazer um comentário.

Olá, bem-vind@!

Quer participar e contribuir? Clique no botão "Registrar-se" se é sua primeira vez aqui. Se você já é um dos nossos, clique em "Entrar".

In this Discussion