Não conecto com Fedora numa VPN PPTP

editado abril 19 em Fedora

Olá! Não consigo me conectar a uma VPN PPTP com o Fedora 31(KDE) e 32(XFCE). As mesmas configurações foram aplicadas em um Mint 19.3(XFCE) e conecto com sucesso.
A única diferença da interface de configuração é na guia GERAL de um sistema para o outro, que serve para a escolha da zona do firewall. No Fedora é possível escolher, mas no Mint não (pela GUI).

Tela de configuração do firewall.
Obs: adicionei o serviço dhcp na interface, adicionei a porta 1723 e 47 na zona pública e escolhi a mesma.

Configuração básica da VPN

Configuração avançada da VPN. Obs: o protocolo MSCHAP v.2 é o necessário para conexão.

A conexão chega a pedir a senha para login, mas depois de alguns segundos não há resposta e não conecta.

Alguém tem alguma ideia de como posso resolver?

Grato!

Comentários

  • Digite seu comentário

  • Já tentou desabilitar o firewall e deixar o selinux permissive? Senão faz um teste ;)

  • Digite seu comentário> @Chacal disse:

    Já tentou desabilitar o firewall e deixar o selinux permissive? Senão faz um teste ;)

    Chacal, o selinux ja estava no permissive, mas não tinha desabilitado o firewall ainda. Fiz e passou na hora. O ideal agora é adicionar a regra no firewalld para não ter que ficar desabilitando sempre que precisar. Qual o nome do serviço de VPN no Fedora? Você sabe?
    Vlw, obrigado pela ajuda.

  • editado abril 19

    Olá Flira,

    Legal, agora sabe que é o firewall que está fazendo o bloqueio.
    Sim, o ideal é adicionar a regra no firewall. Se fosse o iptables eu saberia melhor ... mas o firewalld eu já não manjo mto e até desabilito por isso "não recomendo desabilitar".

    Mas acho que o firewalld vc consegue fazer a liberação da porta.
    firewall-cmd --add-port=XXX/tcp --permanent
    firewall-cmd --reload
    firewall-cmd --list-port

    Tenta assim pra ver.
    Qto ao nome do serviço, aqui no meu é o openvpn.
    Faz um teste assim owww, eu fiz aqui.

    ps aux | grep vpn
    Não vai aparecer nada.

    Aew vc ativa a conexão vpn e repete o comando. Ele vai mostrar os processos ... fica mais facil vc achar e usar no firewalld.

  • Vlw @Chacal!! Eu me viro com os comandos do firewalld, tem muita fonte dele. Eu já havia feito a liberação por porta e não deu certo, mas vou tentar com mais calma e fazer como vc falou pra achar o serviço. Assim que eu resolver eu coloco aqui.
    Abraço!

  • Digite seu comentário> @Flira00 disse:

    Vlw @Chacal!! Eu me viro com os comandos do firewalld, tem muita fonte dele. Eu já havia feito a liberação por porta e não deu certo, mas vou tentar com mais calma e fazer como vc falou pra achar o serviço. Assim que eu resolver eu coloco aqui.
    Abraço!

    Você já conseguiu resolver? posso fchar o tópico?

  • Não resolvi ainda. Segue saída do ps aux. Tentei alguns serviços desses ai mas não resolveu. Adicionei a interface ppp0 e e pppt, bem como as portas tcp 8084 e 8340 na zona publica, mas ainda não resolveu.

  • editado abril 23

    Enquanto isso vai ter que ir desabilitando o firewalld rsrs.
    Não seria o serviço pptpd amigo?

    Eu estava pesquisando a respeito p/ te ajudar e vendo um tutorial ... p/ identificar o nome do serviço usado no CentOS. E foi usado os seguintes comandos do systemd.

    systemctl start pptpd
    systemctl enable pptpd.service

    Aew imagino que deve ser este que vc deve liberar no firewalld.

  • Hehehe estou desabilitando quando preciso entrar na VPN.
    O Serviço não é o pptpd, pelo menos no Fedora com o KDE é diferente.
    systemctl start pptpd
    Failed to start pptpd.service: Unit pptpd.service not found.

    E adicionando no firewall da que o serviço não existe:
    sudo firewall-cmd --permanent --add-service=pptpd --zone=public
    Error: INVALID_SERVICE: 'pptpd' not among existing services

Entre ou Registre-se para fazer um comentário.