[Resolvido] - DÚVIDA - REMI`S RPM REPOSITORY *VERSÕES ANTIGAS PHP*

editado março 2019 em Workstation

Olá,

Eu sou desenvolvedor web e utilizo a linguagem PHP, o fedora sempre traz por padrão uma versão bem recente do PHP , porém eu preciso ter em meu sistema fedora a opção de instalar mais de uma versão do php para manter suporte em projetos legados em verões antigas...

para eu conseguir instalar uma versão antiga eu encontrei o essa opção "remi`s repository"

EXEMPLO:

sudo dnf install http://rpms.remirepo.net/fedora/remi-release-29.rpm
sudo dnf --enablerepo=remi install php70-php-fpm

Minha dúvida é se é seguro usar esse remi repository , ou eu posso quebrar o sistema.

Comentários

  • Você esta utilizando qualquer outro repositório não oficial como rpmfusion ou negativo17?

  • eu habilitei o rpm fusion free e nofree , e instalei o php que vem por padrão usando o comando.

    exemplo:
    sudo dnf install php-fpm

    por padrão a versão é 7.2.16.

  • Não é aconselhavel utilizar vários respositórios não oficiais. Pode acontecer conflito de libs. Você esta com essa maquina em produção? se não está, faz o teste. Quebrar a distro não vai quebrar assim. Ele vai informar algum erro de conflito caso haja. Para programas, utilizamos o dnf downgrade programa.

  • vou testar aqui para ver como fica ... eu preciso das verões no meu notebook de produção ... mas os fontes tem backup no github estão tá tranquilo testar aqui ...

    sobre o downgrade acho que no caso do php para mim não resolveria né? por que eu prciso ter os 2 (php7.0 e php7.2) ...

    atualmente está no php7.2 se eu usar o comando downgrade ele vai sobrescrever a instalação atual será?

  • Tente o update-alternatives --config php . Aguardamos.

  • Consegui usar as 2 vesões ao mesmo tempo assim:

    instalando o repositorio remi no meu fedora 29.

    sudo dnf install http://rpms.remirepo.net/fedora/remi-release-29.rpm

    sudo dnf --enablerepo=remi install php70-php-fpm php70-php-mysqlnd php70-php-bcmath php70-php-gd php70-php-bz2 php70-php-gmp php70-php-opcache php70-php-tidy php70-php-cgi php70-php-imap php70-php-pgsql php70-php-xml php70-php-cli php70-php-xmlrpc php70-php-common php70-php-intl php70-php-pspell php70-php-xsl php70-php-curl php70-php-json php70-php-readline php70-php-zip php70-php-dba php70-php-ldap php70-php-recode php70-php-mbstring php70-php-enchant php70-php-mcrypt php70-php-soap php70-php-pdo-dblib

    Agora no terminal eu consigo usar o php assim:

    VERSÃO ATUAL 7.2.16
    php -S localhost:9000

    VERSÃO DO PHP 7.0.33
    php70 -S localhost:9000

  • Resolvido?

  • Sim .. essa solução me atende por que eu posso escolher qual versão vou rodar (php) ou (php70).

Entre ou Registre-se para fazer um comentário.