[RESOLVIDO]Impressora Epson L375 - ERRO ao Instalar - Fedora 33 Mate

Amandextra
editado fevereiro 23 em Hardware

Como vocês devem saber, instalar impressoras Epson no Linux é um desafio. No Fedora 33 Mate não é diferente.
A primeira e última tentativa que fiz foi em meados de outubro de 2020, assim que instalei o Fedora 33 Mate.
Eu segui os passos do seguinte vídeo...

PARA MIM, O TUTORIAL DO VÍDEO NÃO FUNCIONOU (FICA O ALERTA)

Segue o link para baixar os drives da Epson L375
https://epson.com.br/Support/wa00821

Clique na opção "Drivers Linux" e busque pelo modelo da sua Epson.

Depois desse procedimento, o CUPS não funciona mais apesar de ter desinstalado os drives da Epson L375

O @VINICIUS_ACCIOLY me ajudou com a configuração através do seu artigo aqui no fórum:
https://fedorabr.org/discussion/514/problemas-com-scanner-epson-l395-com-ip-dinamico/p1

A solução para o CUPS ainda permanece sem solução...

Comentários

  • Gideon
    editado fevereiro 23

    Digite seu comentário> @Amandextra disse:

    Como vocês devem saber, instalar impressoras Epson no Linux é um desafio. No Fedora 33 Mate não é diferente.
    A primeira e última tentativa que fiz foi em meados de outubro de 2020, assim que instalei o Fedora 33 Mate.
    Eu segui os passos do seguinte vídeo...

    PARA MIM, O TUTORIAL DO VÍDEO NÃO FUNCIONOU (FICA O ALERTA)

    Segue o link para baixar os drives da Epson L375
    https://epson.com.br/Support/wa00821

    Clique na opção "Drivers Linux" e busque pelo modelo da sua Epson.

    Depois desse procedimento, o CUPS não funciona mais apesar de ter desinstalado os drives da Epson L375

    O @VINICIUS_ACCIOLY me ajudou com a configuração através do seu artigo aqui no fórum:
    https://fedorabr.org/discussion/514/problemas-com-scanner-epson-l395-com-ip-dinamico/p1

    A solução para o CUPS ainda permanece sem solução...

    Em orientações via Telegram, identificamos que o cups.service não estava conseguindo executar o arquivo cupsd.conf.

    Abaixo segue o comando utilizado para identificar o erro:

    $ sudo journalctl -xe | grep cups
    

    Segue um fragmento da saída do comando:

    Para resolver o problema com o cups, foi realizado backup do arquivo cupsd.conf e o mesmo foi substituído pelo arquivo cupsd.conf.default. Abaixo estão os dois comandos utilizados para tal:

    $ sudo mv /etc/cups/cupsd.conf /etc/cups/cupsd.conf.BKP
    
    $ sudo cp /etc/cups/cupsd.conf.default /etc/cups/cupsd.conf
    

    Para iniciar o cups foram executados os comandos:

    $ sudo systemctl stop cups
    $ sudo systemctl start cups
    

    Feito isso, foi executado o comando abaixo para verificar o status do serviço cups:

    $ sudo systemctl status cups
    

    Como podemos ver na imagem abaixo, o serviço está ativo (1) e em execução.

    Entretanto, foi identificado que o filtro necessário para que a impressora imprima os arquivos não foram localizados (2). O processo para resolução desse imprevisto está em análise, e assim que houver uma resolução será reportada aqui.

  • Amandextra
    editado fevereiro 23

  • Depois das configurações que o @Gideon me instruiu a fazer, o CUPS voltou a funcionar

  • Digite seu comentário> @Amandextra disse:

    Depois das configurações que o @Gideon me instruiu a fazer, o CUPS voltou a funcionar

    Amanda, quando for resolvido o problema com o filtro de impressão, posta aqui o processo realizado.

  • Amandextra
    editado fevereiro 23

    Para fazer os seguintes passos que o @VINICIUS_ACCIOLY me ensinou, ligue a impressora para poder ser detectada

    Vá em "Sistema", "Administração" e depois "Configurações da impressora"

    Irá abrir:

    Clique em "Desbloquear", digite sua senha. Uma vez desbloqueado, clique em "Adicionar", onde irá abrir a seguinte janela:

    Clique em "Network Printer" (Impressora de rede)

    Depois, "Avançar", irá abrir:

    Para melhor identificar, @VINICIUS_ACCIOLY sugeriu que eu editasse o "Nome da Impressora" "Wifi-Epson-L375" e assim o fiz. Clique em "Aplicar". Irá abir a página:

    Em "Testes e manutenção" clique em "Imprimir página de teste".

    Aqui funcionou!!!

    Já que as opções que apareceram automaticamente não funcionaram, vamos voltar em "Sistema", "Administração" e depois "Configurações da impressora"

    Desbloqueie novamente. Clique com o direito do mouse sob as duas primeiras e exclua (uma de cada vez)

    Depois de ter feito o teste de impressão com sucesso, testamos o "Digitalizador de documentos". Para acessar o digitalizador com mais facilidade: Alt+F2 e digite "Digitalizador de Documentos", dê dois cliques ou selecione e cliquei em "Executar".

    Coloque algum papel com texto ou imagem no scanner da sua multifuncional . Clique em "Digitalizar"

    Usei a mesma página de teste de impressão para escanear e deu tudo certo!!!

    Se quiser fazer ajustes para melhorar a qualidade da imagem escaneada vá na barrinha de sanduíche e selecione "Preferências":

Entre ou Registre-se para fazer um comentário.